Espace de récupération corrompu?...

Quietman

Nouveau membre
#1
Bonsoir à tous,
j'ai un problème lorsque je veux réinstaller ma sauvegarde sur mon système.
(Veuillez excuser la longueur du post, mais cela fera gagner du temps en donnant toutes le infos que j'ai à ma disposition). Merci.

Mon système d'exploitation est Win 10 Pro version 1903 build 18362.418. Je joins des images de ma configuration. Mon disque système est un SSD Samsung Evo 970 partitionné en C: (220 Go) et D: (730 Go).

La sauvegarde ne parvient pas à se réinstaller sur C: et D: et le logiciel me propose alors de faire une réinstallation secteur par secteur. Impossible car après le premier essai, mon disque de boot se transforme automatiquement en espace non alloué et la partition réservée de 500 Mo prend alors la lettre C: Il n'y a donc pas assez d'espace pour réinstaller ma sauvegarde.
Comment se fait-il que mon disque d'amorçage partitionné C: (220 Go) et D: (730 Go) se transforme en un espace non alloué de 931 Go lorsque j'essaie de réinstaller mon image et que la partition réservée de 500 Mo devienne alors la partition C:? cf Photos "After Recovery".

J'ai essayé de réinstaller 2 de mes images mais le problème est le même. J'ai testé l'intégrité de mes 2 images et tout est OK.
J'ai réinstallé Win 10 Pro plusieurs fois en supprimant et en recréant les partitions sur le SSD et en les formatant avant de réinstaller Win10, mais la procédure de recharge d'image supprime toujours l'espace alloué à C: et D: et attribue la lettre C: à la partition réservée de 500 Mo.
J'ai besoin de votre aide pour pouvoir réinstaller mon image sans perdre l'espace alloué à C: et D: et aller à la fin de la réinstallation de mon image.
Après des années de pratique, c'est la première fois que cela se produit.


Précisions:

1SSD Samsung EVO 970 NVMe 1To (disque 2 partitionné en 2 soit C: et D: + 2HDD SEAGATE FIRECUDA 2T ST2000DX002 (disques 0 et 1, chacun partitionné en 2 soit E: et F: et G: H:.
Donc, mon système a 6 partitions: de C: à H: (C: - D: - E: - F: - G: - H : )

Lorsque je boote depuis le CD-Rom de Windows et que je vais dans les "Options de démarrage avancées" -> Résolution des problèmes-> Invite de commande
x:\ sources, je vois:
Dir C: je trouve en réalité la partition E:
Dir D: Je trouve en réalité la partition F:
Dir E: je trouve en réalité la partition G:
Dir F: je trouve en réalité la partition H:
En tapant G: je trouve en réalité la partition C:
Dir H: je trouve en réalité la partition D:


Je vous envoie la photos prise avec diskpart sous "Options de démarrage avancées" à partir du boot du CD Rom de Win10 cf "BootWinRe.png" et la photo du diskpart fait à partir de l'invite de commande du système Windows 10 "BootOS10.jpg".

Vous verrez que ma partition de démarrage C: 219 Go apparaît avec la lettre G: dans l'invite de commande du CD-Rom et que toutes les lettres des lecteurs et partitions sont mal attribuées dans cet environnement WinRE du CD Rom, alors que sous Win10, les lettres sont correctement attribuées dans le gestionnaire de disques et dans l'invite de commande diskpart lancée depuis l'OS Win10 installé.

Les informations affichées diffèrent d'un diskpart à l'autre selon que je le lance avec le CD Rom d'installation Win10 (photo "BootWinRe.png" avec mauvaises informations dans les lettres des partitions) ou selon que je le lance à partir du système installé (cf. "BootOS10.jpg" informations correctes affichées).

Sur la photo "BootOS10", les lettres sont bien attribuées mais ces informations ne sont pas les mêmes que celles affichées sur "BootWinRe.jpg".

Je pense que ces mauvaises attributions de lettres aux partitions dans l'environnement WinRe à partir du CD Rom peut expliquer mon problème lorsque je veux recharger une sauvegarde système.

La partiton C: affichée dans le diskpart de l'OS installé Win10 (correct) se retrouve à la lettre G: dans le diskpart affiché depuis le CD Rom Win10 AdvancedBootOptions"/troubleshooting->invite command (pas correct).
Ceci pour toutes les partitions:
la partition C de 219Go qui est correcte sous le diskpart de l'OSWin10 se retrouve en G dans le diskpart depuis le CD Rom Win10
la partition D de 730Go correcte se retrouve en H
la partition E Work1 correcte se retrouve en C
la partition F Work2 correcte se retrouve en D
la partition G Storage1 correcte se retrouve en E
la partition H Storage2 correcte se retrouve en F


Comment fixer çà? Il faudrait que toutes les lettres affichées dans le diskpart sous l'OS Win10 et qui sont correctes soient identiques dans le diskpart affiché depuis le CD Rom Win10 AdvancedBootOptions"/troubleshooting->invite commandes où elles ne sont pas correctes.

Mon bios affiche correctement les informations de boot puisqu'il voit bien le SSD de 931Go et les 2 HDD et que mon OS Win10 démarre bien sur C:.

Je joins aussi une capture Gestion _disques sous Windows réinstallé.

J'espère que vous pourrez m'apporter votre soutien pour résoudre çà car, je ne sais pas comment procéder pour m'en sortir.
Merci d'avance
 

Fichiers joints

philou21850

Grand Maître
#2
Débranche tout tes lecteurs disques et HDD qui sont en SATA pour laisser que ton NVme.
Dans Diskpart, c'est toujours comme çà.
C est nommé E, F, Z ont s'en cogne.
Puis injecte ton image sur le NVME.
 

Quietman

Nouveau membre
#3
Bonjour Philou21850,
Merci de ta réponse. J'ai suivi tes conseils mais ça n'a pas marché en utilisant mes anciennes sauvegardes. J'ai donc réinstallé Win10 et fait une sauvegarde test que j'ai rechargée sans et ensuite avec les disques SATA connectés et ça a fonctionné les deux fois.
J'en déduis que mes 2 anciennes sauvegardes étaient corrompues malgré le check positif du soft de sauvegarde. Il ne me reste plus qu'à réinstaller tous mes softs! Mais au moins tout sera clean.

Merci pour ton support.
 
Dernière édition:

philou21850

Grand Maître
#4
Bonjour Philou21850,
Merci de ta réponse. J'ai suivi tes conseils mais ça n'a pas marché en utilisant mes anciennes sauvegardes. J'ai donc réinstallé Win10 et fait une sauvegarde test que j'ai rechargée sans et ensuite avec les disques SATA connectés et ça a fonctionné les deux fois.
J'en déduis que mes 2 anciennes sauvegardes étaient corrompues malgré le check positif du soft de sauvegarde. Il ne me reste plus qu'à réinstaller tous mes softs! Mais au moins tout sera clean.

Merci pour ton support.
Tes images avait peu-être des versions différentes " 1803 vers 1903 " ne fonctionne pas car Windows change un paramètre du disque système " UEFI " créé des partitions un peu différente.;)
 

Quietman

Nouveau membre
#5
Tes images avait peu-être des versions différentes " 1803 vers 1903 " ne fonctionne pas car Windows change un paramètre du disque système " UEFI " créé des partitions un peu différente.;)
Oui je pense tu dois avoir raison car j'ai récemment mis à jour Window10. Et mes sauvegardes dataient un peu! De toute façon l'éditeur du soft que j'avais contacté n'arrivait pas à trouver le problème. Ça devenait compliqué...
 

chonos

Helper
#6
Donc en conclusion, il faut faire une sauvegade Brut des data sur un format qui ne bouge pas ! ou du moins qui soit diférent de l'original. Cela deviens de plus en plus compliquer de faire de la vrais sauvegarde pérène !

Mais la seul chose qui tiens la route c'est de se passé des softs de sauvegarde et de l 'OS !
 

philou21850

Grand Maître
#7
Il faut faire des images et sauvegardes régulièrement, supprimer les anciennes.
 

magellan

Modérâleur
Staff
#8
Donc en conclusion, il faut faire une sauvegade Brut des data sur un format qui ne bouge pas ! ou du moins qui soit diférent de l'original. Cela deviens de plus en plus compliquer de faire de la vrais sauvegarde pérène !

Mais la seul chose qui tiens la route c'est de se passé des softs de sauvegarde et de l 'OS !
Oui... mais non. Les sauvegardes peuvent se traiter d'énormément de manières, et une image ISO d'un système n'est pas forcément la chose la plus fiable au titre qu'il suffit de ne pas refaire l'ISO régulièrement pour que les mises à jour deviennent ensuite un enfer après restauration. Pire encore: quand 10 a été distribué "gratos" sur les mises à jour de système, qui a fait un backup avant/après? Personne sauf en entreprise... et encore.

La bonne politique? Choisir la stratégie en fonction de l'environnement et des moyens, sauvegarder le vital quitte à perdre l'OS (fichiers personnels en tête de liste), et ne surtout pas compter que sur un seul support.
 
Vous devez vous inscrire ou vous connecter pour répondre ici.
Staff en ligne
  • magellan
    Modérâleur
  • AccroPC2
    Modérateur
Membres en ligne
  • vaelis
  • nono_el_bonobo
  • magellan
  • SergioVE
  • Bravest
  • AccroPC2
Derniers messages publiés
Statistiques globales
Discussions
865 920
Messages
8 062 869
Membres
1 576 452
Dernier membre
Nestaa
Partager cette page
Haut