Passage d'un iMac 27 à la construction d'un Hackintosh

  • Auteur de la discussion superdskkkk
  • Date de début

LeeLarant

Speedy Configales, le plus rapide de tout TH
Staff
#161
Ça serait génial. :)
 

superdskkkk

Expert
#162
Hello le forum,

Petit retour sur mes premiers pas sur un hackintosh. Aujourd'hui j'ai réalisé l'installation de macOS après des semaines de lectures et recherches avec comme sujet principal OpenCore et mes nombreuses questions.

L'idée de base était de switch de MAC à PC, je supportais plus vraiment la politique d'Apple et le non upgrade d'une machine. Je voulais aussi avoir le meilleur des deux mondes. J'ai déjà windows sur mon imac de 2015 via bootcamp mais bon, sans upgrade au bout d'un temps la machine montre aussi ses limites.

Bref, comme ça à chaud après la réussite de ma première installation. Faire un hackintosh ça demande grave du temps mais l'aventure est cool! :) Il me reste énormément de questions, un peu de post-installation à faire. OpenCore est un bootloader vraiment dingue, c'est ultra bien fait.

La route est encore longue! :ROFLMAO:

captureecran.jpg
 
Dernière édition:

superdskkkk

Expert
#163
Hello le forum,

Je reste dans l'idée de maintenir mon post à jour dans mon aventure pc/mac. :)
Petit rebondissement, mercredi soir mon pc est parti dans une boucle de redémarrage sans fin. Je précise que j'étais sous windows et non sur le hack, bref j'étais sur le cul quoi... Super c'est quoi cette merde.

Première pensée, ok c'est OpenCore qui fait de la merde. J'étais pas bien. Je commence donc à réfléchir.

Je refais ma clé de boot windows en me disant stop c'est terminé OpenCore.
Je formate l'ensemble des SSD avec diskpart
Je pars dans une nouvelle installation de windows.

Idem, je passe même pas l'installation dans sa totalité, ça reboot. Je me dis ok, je reste un peu sur le BIOS voir si l'alimentation n'est pas en cause, le BIOS voit bien mes composants, ram, processeur, ssd, la T° est bonne.

Bref la boucle de reboot revient en voulant refaire un essai d'installation.

Je clear CMOS, je retire la pile de la CM, je sors la ram histoire de voir. Toujours cette boucle de reboot. N'ayant plus le choix, j'ai pris ma machine direction matériel.net, une boutique est à 5min de chez moi (strasbourg).

La machine reste sur place pour des recherches de pannes, j'ai acheté une partie des pièces chez eux (CM-Proc-RAM-Alimentation). Je viens d'avoir le technicien au téléphone, c'est le ryzen qui est mort :LOL:

Bon tout est sous garantie donc rien de grave. Une aventure de plus. Mais finalement le technicien était vraiment cool, matériel.net c'est des prix un peu plus haut mais franchement je suis bien content d'avoir une personne physique en face de moi et de pouvoir discuter tranquillement avec le technicien.

La suite d'ici peu! Bon weekend à tous :)
 

LeeLarant

Speedy Configales, le plus rapide de tout TH
Staff
#164
Hi
Tes rams étaient bien sûr les slots 2 et 4 en commençant par la gauche?
:)
 

superdskkkk

Expert
#166
Hi
Tes rams étaient bien sûr les slots 2 et 4 en commençant par la gauche?
:)
Yes tout était ok pour la ram :) Je copie/colle le mail du technicien. Il a simplement fait le test des différents composants pièce par pièce. Difficile à faire quand t'as que un pc. C'est rien de grave :) Je voulais juste partager la chose, histoire de maintenir mon post à jour. Peut-être que ça peut aider des gens.

image.jpg
 

superdskkkk

Expert
#167
Hello le forum, petite question concernant la surveillance des T° sur windows. J'utilise HWMoniteur qui fonctionne parfaitement + CPU-Z.

Vous pensez quoi de Core Temp? Je trouve plutôt cool l'idée d'avoir des infos dans la barre à côté de l'heure sur la droite. Des gens utilisent ce petit programme? Merci pour les retours :)
 

LeeLarant

Speedy Configales, le plus rapide de tout TH
Staff
#168
Oui, parfait. :)
 

superdskkkk

Expert
#170
Hello le forum, j'espère que tout roule pour vous tous!

Je reviens après pas mal de travail sur mon hackintosh. Les choses avancent très bien ça fait plaisir! Il ne me reste plus grand chose à faire dessus avant de pouvoir vraiment travailler avec. :)

Voilà un petit point sur les choses fonctionnelles :

Wifi/Bluetooth : OK
J'utilise une carte pci Fenvi T919, elle est reconnue nativement sans kexts, sans rien faire. C'est un vrai plus! Sur ma asus x570 c'était l'unique solution stable et viable.
Le wifi 6 AX200 est pour le moment très mal supporté sur un hackintosh. J'ai même pas essayé de le faire. Il est utilisé uniquement sur win10.

Sous macos Fenvi T919 / Sous win10 le matos wifi/bluetooth de la CM.

Ethernet + Ethernet 2.5G : OK
Idem tout roule sur les ports de la CM. Les débits sont identiques a win10. Le port 2.5G est pas reconnu nativement même avec les kexts. Il faut faire un ajustement, après ça déroule.

CG 5700XT nitro+ : OK
Bon là, pas de surprise! La carte fonctionnement nativement avec les bons arguments de démarrage dans le fichier config.plist de opencore. Il faut voir dans le temps en session de travail, comment elle est. Je cherche encore un moyen pour avoir la surveillance des T° comme sur win10.

Les nouvelles CG AMD sont pour le moment pas totalement supportées sur Big Sur. Perso je suis sur Catalina, Big Sur c'est encore le début du coup l'option stabilité étant plus importante à mes yeux.

RAM PROC : OK
Idem ici. La communauté hackintosh AMD est dingue! Tout fonctionne parfaitement dans les T°, vitesse et tout. Chose importante les nouveaux proc 5xxx fonctionnent, ça c'est cool pour l'upgrade dans le futur.

Le profil XMP/DOCP de la ram ne fonctionne pas vraiment d'après mes lectures. Il y a des paniques dans le noyau. Du coup idem, j'ai pas fait le test. J'ai 2 profils de BIOS un pour macos l'autre pour win10 avec le XMP/DOCP à 3200. Mais au final je suis souvent, même sur win10 sans le XMP/DOCP. La quantité de ram est reconnue directement.

SERVICES APPLE : OK
C'est franchement le truc le plus cool pour moi. Venant de chez Apple, c'est vraiment des fonctionnalités importantes entre mes machines surtout AirDrop. Tout marche parfaitement :

- iCloud
- iMessage
- AirDrop
- FaceTime (je ne sais pas, je n'ai pas de webcam, pour l'instant ma machine est branchée sur la TV du salon).
- Partage de la 4G depuis mon iPhone
- SIP (sécurité de la partition système) (c'est un truc apple qui me gave depuis que ça existe mais bon ça fonctionne aussi, c'est l'idée du hackintosh pour moi, être comme sur un vrai mac).

Pour faire vite, tout fonctionne, enfin l'ensemble des choses que j'utilise au quotidien sur mes mac, c'est la même sur le hack.

///

Les choses à faire encore :

CARTOGRAPHIE USB :
Refaire la cartographie des ports USB, c'est le gros morceau! L'ensemble de mes ports USB 2.0 et 3.0 marchent. Le problème est que sans cartographie USB je ne peux pas mettre en veille la machine. Enfin c'est possible, mais la machine ne sort pas de la veille et il y a une panique du noyau.

C'est un problème connu sur AMD. C'est juste long à faire et je suis pas encore au point avec toutes mes lectures sur le sujet :) C'est le prochain chantier!

FILEVAULT :
C'est le système de chiffrement des données... Perso j'ai jamais utilisé ce truc sur mes mac mais bon, dans l'idée d'être comme un vrai mac, je vais le faire.

DOING DE DÉMARRAGE :
Le fameux bruit made in apple. Idem c'est pas compliqué à mettre en place. Ce que je trouve plutôt cool avec OpenCore c'est le démarrage du bootlaoder. Mon hack fonctionne avec la DEBUG version et non la release (il est possible de switch les fichiers pour être en release, c'est bien fait!). Du coup j'ai accès à des rapports de boot, je peux avoir un paquet d'infos utiles!

Donc à voir encore si je passe sur un boot type interface bootcamp ou non.

///

Voilà en gros! C'est juste un retour d'expérience pour les gens qui souhaitent peut-être pourquoi pas faire le saut ou simplement voir ce qu'est OpenCore! Si je pouvais revenir en arrière avant l'achat des premières pièces du pc ou choisir l'achat d'un nouveau mac. Je ferai le même choix.

Je pense aussi que le hackintosh AMD est plus simple à faire que le hack INTEL. Chose plutôt drôle en sachant que INTEL est natif sur mac. L'upgrade de proc sur un 5xxx c'est vraiment top!

C'est une aventure vraiment cool le hackintosh, j'ai échangé avec des gens vraiment cool sur les forums :) Je suis graphiste de métier, pas codeur et tout mais j'ai appris pas mal de trucs!
 
Dernière édition:
U

User_1505931

Invité
#171
C'est une aventure vraiment cool le hackintosh, j'ai échangé avec des gens vraiment cool sur les forums :)
Franchement, Bravo d'être allé au bout de ton projet " respect ".(y)
Continue de nous tenir au jus.:merci:
Aussi ton Hack n'est pas près d'être au bout.;)
 

superdskkkk

Expert
#172
Franchement, Bravo d'être allé au bout de ton projet " respect ".(y)
Continue de nous tenir au jus.:merci:
Aussi ton Hack n'est pas près d'être au bout.;)
@philou21850 Merci pour le message! Ça fait plaisir! :) Le projet a véritablement débuté ici avec vous! :love:
 

superdskkkk

Expert
#173
Hello :)

Des nouvelles concernant le hack AMD. L'ensemble est vraiment stable, rien a dire sur les tâches quotidiennes et tout. Le gros point noir concerne AMD et Adobe. C'est la merde :LOL: Du coup je pense partir vers une plateforme INTEL et mettre en vente mon ASUS x570 et mon 3700x.

Je me laisse encore un peu de temps pour la réflexion! :) Mais je pense partir du z490 + 10700k. Si des gens cherchent du matériel encore sous garantie et souhaitent partir sur une ASUS x570 Rog Strix + 3700x vous pouvez me contacter en mp :)
 

LeeLarant

Speedy Configales, le plus rapide de tout TH
Staff
#174
No way...
Y a pas de soluce à cela?
Le 10700k est chaud (au sens propore), gaffe...
 

superdskkkk

Expert
#175
No way...
Y a pas de soluce à cela?
Le 10700k est chaud (au sens propore), gaffe...
@LeeLarant Oui j'ai vu que le 10700k chauffe pas mal, TDP de 125W quoi... Franchement pour l'instant je patiente. Le problème c'est l'écriture logiciel Adobe d'après mes lectures. C'est clairement écrit pour intel.

Sur Ryzen ça marche, ça fonctionne, mais le hack est juste un contournement du truc/problème d'écriture. Je vais voir après les fêtes de fin d'année. Pour l'instant ma x570 et le 3700x ça fait plus que le job dans win10.
 

superdskkkk

Expert
#176
@LeeLarant J'ai une petite question sur ma sapphire 5700xt nitro+ : un truc que je comprends pas.

Si je démarre à "froid", la machine éteinte depuis 1 journée totalement. Après le passage du BIOS quand j'arrive sur win10, la cg part à 2000 RPM. Je dois ouvrir Adrenalin, passer de réglage manuel à par défaut.

J'ai underwolt ma cg histoire d'être bien. Donc j'ai une courbe de ventilation manuelle, vraiment douce. Je suis à 27° en utilisation normale (surf, netflix, mail and co). J'arrive pas à savoir si c'est software ou hardware le problème.

Après ce boot à froid, passage de manuel à défaut puis de nouveau à manuel avec mon profil enregistré tout roule... Je peux reboot 20x la carte est tourne bien elle ne s'emballe plus.

T'as une idée peut-être, un problème de driver?

J'ai déjà : formater > clean install win10 > clean install driver > passage dans le bios de pcie 4 à 3.

Le truc étrange c'est qu'une fois dans la journée... :LOL:
 
Dernière édition:

superdskkkk

Expert
#177
L'image de mon profil CG si jamais quelqu'un a une idée :)

AMD1.JPG AMD2.JPG
 

Melaure

Modérateur
#178
Félicitations pour ce travail !!! Je suis vraiment impressionné !
 

LeeLarant

Speedy Configales, le plus rapide de tout TH
Staff
#180
Après le passage du BIOS quand j'arrive sur win10, la cg part à 2000 RPM. Je dois ouvrir Adrenalin, passer de réglage manuel à par défaut.
C'est un souci logiciel je pense.
Essaie en desinstallant adrenalin?
 
Vous devez vous inscrire ou vous connecter pour répondre ici.
Staff en ligne
  • AccroPC2
    Fou du PC
Membres en ligne
  • ab06
  • MonsieurMammouth
  • AccroPC2
  • chouan12
  • SergioVE
Derniers messages publiés
Statistiques globales
Discussions
838 170
Messages
7 493 940
Membres
1 583 319
Dernier membre
vianka2
Partager cette page
Haut