Probleme RAM sur carte mere P5B

jojo227

Nouveau membre
Bonsoir tout le monde.

Voila, je viens de monter un Core2duo E6400 sur une Asus P5B.

J'installe mes 4 barettes de RAM 1G et tout le reste.(barettes pas identiques, mais bon ca ne change pas le probleme.)

Je demarre et la!!! le bios ne detecte que 3G de RAM au lieu de 4.

Je retourne a Surcouf et on peut pas me repondre sur le probleme.

Je les installes sur une M2N-E d'un pote et son bios trouve les 4G.

Y a t'il une solution pour que ma p...... de carte mere puisse reconnaitre mes 4G.

Merci d avance.
 

boub popsyteam

Grand Maître
Flasher le bios :o

Mais bon c'est une limitation connue des chipsets ... donc j'en déduis que surcouf c'est des pignoufs si ils ne savent pas ça :ange:

Tu ne pourras pas sous un OS 32bits faire afficher / utiliser ta ram en entier.

(sans parler du fait que ça a peu d'utilité)
 

julienche

Nouveau membre
Salut, j’ai exactement le meme soucis que toi, sauf que mes barrettes sont les 4 même et que je suis sous vista….3 semaines que je m’arrache les cheveux….as tu trouvé une solution
Merci de me repondre
Salutations
Juju

Mn mail *******@hispeed.ch

Edit du modo : enlevé l'adresse mail pour éviter le spam
 

misterdav42

Nouveau membre
Pour info et enfoncer le clou !!! même avec une p5w dh qui permet, après un petit réglage dans le bios, de vois 4go de ram, les version 32 bits des différent windows (xp ou vista) ne voient que 3Go mais savent qu'il y a 4 Go mais s'en sert pour des fonctions qui nous dépassent.

Et même en demandant à un ingénieur.... j'suis même pas sur d'avoir une réponse simple et claire.

Enfin vivement le 64 bits qui nous permettera de voir jusqu'à 8Go mais à quand les applications qui exploiteront et tourneront réellement en 64bits et ne seront pas uniquement compatible 64 bits !!!!
 

boub popsyteam

Grand Maître
Réponse simple et claire: c'est expliqué dans la doc de la carte mère pas besoin d'être ingénieur ...

Pour résumer:
Tes cartes, ports et autres entrées/sorties prennent un morceau de l'espace d'adressage du processeur (32 bits = 4Go) Hors tu ne peux pas avoir et de la mémoire et des entrée-sorties sur la même plage d'adresse.
Donc tu te fais bouffer un morceau de ram non utilisable.
 

NiahBoumPof is back

Grand Maître
Pour résumer:
Tes cartes, ports et autres entrées/sorties prennent un morceau de l'espace d'adressage du processeur (32 bits = 4Go) Hors tu ne peux pas avoir et de la mémoire et des entrée-sorties sur la même plage d'adresse.
Donc tu te fais bouffer un morceau de ram non utilisable.
juste pour savoir ca se monte a combien ?
 

sterfield

Nouveau membre
Salut à tous

Je viens d'acquerir mon nouveau materiel, à savoir P5B Deluxe, avec 4 x 1Go de Corsair. J'ai rencontré les memes problèmes que vous, à savoir 3 Go uniquement détectés par le BIOS.

La bonne nouvelle, c'est que c'est normal :) Par défaut, le bios n'ai configuré que pour gérer 3 Go, mais il peux passer facilement à plus. Pour cela, il faut activer l'option memory remap features dans le menu northbridge. (j'ai trouvé cette info bien planquée dans la FAQ d'Asus : )

EDIT : je n'ai pas réussi à linker le post de la FAQ d'Asus correspondant, je vous quote le contenu.
Question

My P5B series motherboard suppose to suppose up to 8GB of RAM. However, I cannot get even close to 4GB in total under Windows XP/2000/2003.
Why is that? Is there anything I can do to fix this?

Answer

There are two parts to this question:
1. Limitation of operating system.
2. Limitation of X86 compatible computer architecture.

OS wise, it is known that due to limitation of 32bit OS (e.g. Windows XP/2000/2003), it will not be able to address the full capacity of 4GB as it supports up to 4GB of RAM at max, but some of the addressing bits are used up for addressing PCI/PCI-e devices.
Please kindly switch to use 64bit operating system such as Windows XP 64bit or Server 2003 64bit to enable support of the full capacity of your RAM.

Hardware wise, please simply enter BIOS setup screen, and set "Advanced-->Chipset-->Northbridge Configuration-->Memory Remap Feature" to "Enabled".

If both requirements are fulfilled, your system should then be able to detect the full capacity of your RAM when 4GB or more RAM are installed onto this system.

Cependant, l'OS limite egalement la taille de la mémoire. XP 32 bits ne pourra jamais depasser 3 Go de mémoire gérée. Pour avoir la totalité de la mémoire gérée par l'OS, il faut soit avoir XP 64 bits, 2003 Server, ou Vista (ces deux derniers 0S ayant été développés pour supporter la totalité de l'espace adressable d'un processeur 32 bits, soit 4 Go).

Le problème, c'est que si vous activez l'option du bios "memory remap features", Windows XP ne detectera que 2 Go de RAM, alors que le bios vous detectera bien la totalité des 4 Go.

Donc, en résumé :
■ Soit vous avez Windows XP 32 et dans ce cas, n'activez pas "memory remap features". Vous n'aurez que 3 Go de detectés dans le BIOS, et vous retrouvrez ces 3 Go dans Windows.
■ Soit vous avez un OS supportant la totalité de vos 4 Go (Vista, XP 64, 2003) et dans ce cas, activez "memory remap features". 4 Go de detecté dans le bios, 4 Go dans l'OS.

En esperant avoir aidé :)
 

ced@

Expert
Réponse simple et claire: c'est expliqué dans la doc de la carte mère pas besoin d'être ingénieur ...

Pour résumer:
Tes cartes, ports et autres entrées/sorties prennent un morceau de l'espace d'adressage du processeur (32 bits = 4Go) Hors tu ne peux pas avoir et de la mémoire et des entrée-sorties sur la même plage d'adresse.
Donc tu te fais bouffer un morceau de ram non utilisable.

Donc si j'ai tous bien compris si on met 4Go l'os en bouffe 1 en ressource diverses donc on en vois 3, mais pourquoi on a pas le meme phènomène avec 2 Go d'installer?


 

NiahBoumPof is back

Grand Maître
Donc si j'ai tous bien compris si on met 4Go l'os en bouffe 1 en ressource diverses donc on en vois 3, mais pourquoi on a pas le meme phènomène avec 2 Go d'installer?
hum donc non apparement t as pas compris, en simplifié ca donne
le processuer a 4Go d'espace adressable
parmis ces 4Go il y a la ram et les autres perif a acces direct
tant que tu mets 3Go ou moins de ram, tu en auras la totalité, par contre si jamais ca depasse 3Go la ca viendrait empieter sur l'acces aux autres perifs. Pour eviter cela ton os masque cette ram en trop
 

julienche

Nouveau membre
salut, cool et un grand merci, j'ai bien activé le memory remap features, mais maintenant mon bios reconnait bien 4 gig de ram,,,,,mais pas mon os...qui est vista,Vista de reconnait que 2048 avec le memory remap features actif....que faire
merci
bon w-e
juju
 

sterfield

Nouveau membre
Hello

Je complete les infos que j'ai deja donné auparavant avec cette nouvelle FAQ, toujours tirée du site d'Asus :

The available memory under 32-bit Windows XP is 2GB only when I have 4GB memory installed and memory remap enabled in BIOS. When I disable memory function in BIOS, the available memory under 32-bit Windows XP becomes 2.93GB. How do I fix this?

This is a limitation of 32-bit Windows XP. When the memory remap function is enabled, the occupied memory address is remapped to above 4G. In addition, the remap is done in 1G block as an unit. Since the available memory is 2.93GB without remap, when remap is enabled, the memory address between 2-4GB is remapped to above 4G. However, 32-bit OS does not recognize anything above 4G. Consequently, the remapped 2GB is lost. The available memory address under 32-bit OS is reduced to 2G. Hence under 32-bit OS, it is recommended to keep remap function disabled.

Maintenant, le fait que ton OS ne gere que 2 Go m'etonne un peu. Essaye de trouver une option appellée PAE pour "Physical Adress Extension". C'est le systeme mis en place par Crosoft pour gérer les extensions de mémoire. Désolé de ne pas etre plus précis, je ne suis pas encore passé à Vista (les drivers de ma carte mère sont encore en beta, on va attendre un peu :)à

Bon courage à toi?
 

NiahBoumPof is back

Grand Maître
euh si tu as la version entréede gammede vista (la moins chere) c est normal : ca ne gere pas le 64bits
 

sterfield

Nouveau membre
Un processeur 32 bits (comme c'est le cas ici) peut gérer jusqu'a 4 Go Maximum de mémoire adressable. Mais on a vu que Windows XP 32 bits est limité par sa construction à maximum 3Go de mémoire vive.
Cependant, par une procédure appellée "PAE", il est possible de remapper des quantités de RAM supplémentaires à 4 GO (donc superieur à ce qu'un processeur 32 bits peut gérer) pour gérer des quantités supérieurs.

Bon maintenant, revenons sur la carte mére P5B. Voila ce qui est acquis :
■la P5B gère jusqu'a 3 Go de RAM sans remapping
■pour gérer plus de 3 Go de RAM, il faut activer le remapping (c'est le cas pour julienche). Cependant (et c'est là que le bordel commence), en remappant la mémoire RAM dans le BIOS, la P5B gère les 2 premiers Go dans l'espace d'adressage géré par un processeur 32 bits et remap la quantité de RAM restant au délà de 4 Go (donc dans un espace d'adressage pas géré par un processeur 32 bits). C'est "clairement" indiqué dans la FAQ d'ASus :
Since the available memory is 2.93GB without remap, when remap is enabled, the memory address between 2-4GB is remapped to above 4G. However, 32-bit OS does not recognize anything above 4G. Consequently, the remapped 2GB is lost. The available memory address under 32-bit OS is reduced to 2G.

Pour pouvoir gérer la quantité de RAM mappé au delà de 4 Go, il faut activer le PAE (Physical Adress Extension) pour que Windows sache qu'il y a de la RAM disponible au dessus de l'espace d'adressage du processeur 32 bits.

Windows 32 bits ne dispose pas de la procédure PAE. Vista et Windows 2003, oui. D'où mon conseil de trouver comment activer le PAE sous ton Vista, pour qu'il retrouve tous ses petits, à savoir tes 2 Go de mémoire disparues.

Je sais pas si j'ai été très clair... :D

EDIT : Je crois avoir trouvé ce qui t'interessais !
En gros, une option a activer dans le Boot.ini de Windows et ca roule :)
 

julienche

Nouveau membre
merci pour ton aide et ton soutien dans ma quete sterfield.....j'ai lu l'article mais alors la je pige passe qu'il faut faire et comment modifier le boot.ini, si quelqu'un a une idée
merci
ju
 

sterfield

Nouveau membre
Essaye ca :

En gros, il faut rajouter l'option /PAE dans le fichier Boot.ini.

EDIT : Pfff j'adore la logique Crosoftienne. Alors, pour activer le PAE dans Windows Vista, ils te disent de mettre l'option /PAE dans le fichier Boot.ini. Sauf que ce fichier a disparu dans Vista :heink:

Alors du coup, il faut utiliser la commande "bcdedit" dans un terminal

Bon courage.

EDIT 2 : Hop là, un ptit passage par le tech Center Vista de nos amis Crosoft, histoire de trouver ce qu'il fallait concretement faire pour activer le PAE. Tout est expliqué ici :
 

julienche

Nouveau membre
hello, merci pour ton aide,,,tres pointue, mais trop pour moi et mes 2 ou 3 notions, si je comprends je dois modifier le boot.ini, mais je ne sais pas comment le faire et se que tu entends par utilier la commande dvdedit dans un terminal.....si je peux encore abuser de votrre aide
merci encore
juju
 

sterfield

Nouveau membre
Hello :)

Reponse courte : RTFM : . Mais bon, je concois que ca puisse etre un peu obscur, malgré que ca soit assez bien expliqué et detaillé.

Donc, je vais faire une...

Réponse longue :

En fait, et pour faire simple : Tu as Vista, il permet de gèrer l'intégralité de ta RAM, à savoir tes 4Go. Cependant, va savoir pourquoi, il n'est pas activé pour gérer plus de 2 GO.

Pour qu'il puisse retrouver tous ces petits et gérer plus de 2 GO, il faut activer le PAE. Celui ci s'active à l'aide de la commande bcdedit.

On va y aller pas à pas :
■Ouvre un terminal
■tappe la commande : bcdedit /set pae forceenable. Ca doit demarrer le PAE pour ton systeme.
■Reboot et ca dois etre bon.

Bonne chance à toi.
 
Vous devez vous inscrire ou vous connecter pour répondre ici.
Derniers messages publiés
Statistiques globales
Discussions
730 052
Messages
6 716 118
Membres
1 586 167
Dernier membre
Spartacus1
Partager cette page
Haut